How to Upgrade Your ASP.NET 1.1 or ASP.NET 2.0 Plan to a Newer Plan

Upgrade Your ASP.NET 1.1 or 2.0 Plan to a Newer Plan

The older ASP.NET plans are considered legacy scripting languages and as such we recommend upgrading your hosting account and the code of your site. 

In order to change your plan, you will need to submit a "Change Plan Request" in the WebControlCenter.
  Before submitting the Change Plan Request there are a few requirement and things you should know about.


Upgrade Requirements


Before you start the process of upgrading your hosting account there are a few things you should be aware of.
  • We cannot guarantee that the code of your site will function on the new server.  It is your responsibility to correct any coding issues caused by the upgrade.  If you have any concerns about your site not working we do offer a service to review the code of your site.  If you are interested in having us perform a Code Review for you please let one of our agents know.  Please see KB 1682 for our Contact Us information.
  • During the process of upgrading your hosting account the IP address associated with your hosting account will change.  You will receive the new IP address after the upgrade has completed via email.
  • If you are using a shared SSL the shared SSL will change as you migrate to a different web server with its own Shared SSL.  Once the upgrade has completed you will be able to log into the WebContolCenter and navigate to Site > Site Overview to see the new shared SSL.
  • As Microsoft no longer supports FrontPage extensions, our newer plans/servers no longer support their use. 
  • If your site utilizes and MSSQL 2000 or 2005 database it will need to be upgraded to a MSSQL 2008 database as the new plans do not support the older databases.
    • For information on how to upgrade your MSSQL database please see KB 1365.
  • If your site utilizes a MySQL 4 database it will need to be upgraded to MySQL 5 as the new plans do not support the older databases.
    • For information on how to upgrade your MySQL 4 database please see KB 927.
  • If you are planning on upgrading to a ColdFusion 10 plan and you are utilizing an Access datasource, you will need to upgrade that database to an MSSQL database
    • For information on how to upgrade your Access database please see KB 98.
  • If you are not using our name servers you will need to update the DNS records manually once the upgrade has completed.
    • If you are using our name servers we will automatically update the DNS for you.
  • Any FTP passwords will need to be updated once the upgrade has completed
  • Once the upgrade has completed you will need to review your site to ensure that everything is functioning correctly.  If there is an issue please notify us immediately.
  • If you upgrade your hosting account and your site does not function as intended you can request to have one of our agents manually downgrade your hosting account back to the original scripting language.  Keep in mind that after the downgrade you will once again change your IP address and it will not be the original IP address you started with.


Submitting the Change Plan Request

First log into the WebControlCenter at https://www.webcontrolcenter.com/customer.aspx with your Customer ID and password. If you have multiple domains under your account, you'll have an additional step to select your domain--make sure you select the exact domain you wish to move to the new plan.

If you need login help, please click here.

Navigate to Customer > Support Requests > Change Plan Request. 
 


From the drop down menu, select the plan you wish to change to.





Plans Affected by the Price Change


If you are upgrading your plan in order to avoid the pricing change on ASP.NET 1.1 and ASP.NET 2.0 plans, there are a number of plans that are not affected by the pricing change.  We recommend the following plans as they support .NET framework versions: 2.0, 3.5, 4.0, and SQL 2008 or MySQL 5 databases only:
  • ASP/ASP.NET Value - Server 2008
  • ASP/ASP.NET Intermediate - Server 2008
  • ASP/ASP.NET Advanced - Server 2008
  • ASP/ASP.NET Advanced - Server 2008
Please Note: Framework version can be configured in the WebControlCenter under IIS Manager > App Pool Manager.

Once you have made your selections click Next and follow the rest of the required steps. You will be contacted via the email address you provide when the plan change is complete.

Add Feedback